PHP5.3にアップグレードしたらdate関数でエラー警告がでた。

2012 年 3 月 3 日 - PHPのメモ

先日、wordpressのアップデートの為にPHPのバージョンを5.3にアップグレードしたらメールフォームで使ってた自動日時取得項目に下記のエラーが出ました(>_<)

Warning: date() [function.date]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘Asia/Tokyo’ for ‘JST/9.0/no DST’ instead in /(phpファイルのパス) on line (エラー行数)

調べてみるとどうやらdate()関数はphp5.3ではタイムゾーンを正しく設定しないと警告が出るようです。

解決策としては下記のソースを1行付け足すだけでOK(日本国内の場合)

==============================
date_default_timezone_set( ‘Asia/Tokyo’ );
==============================

めでたしめでたし。

東京のホームページ制作会社がオープンしました。

コメントを残す